Skip to main content
← All vulnerabilities
CVE-2022-31777PYSEC-2022-42976BIT-SPARK-2022-31777GHSA-43XG-8WMJ-CW8H

Apache Spark XSS vulnerability in log viewer UI Javascript

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.2.2, 3.3.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Spark

    through 3.2.1

  • pysparkPyPI

    fixed in 3.2.2

  • pysparkPyPI

    From 3.3.0 · fixed in 3.3.1

  • org.apache.spark:spark-core_2.9.3Maven

    All versions

  • org.apache.spark:spark-core_2.13Maven

    fixed in 3.2.2

  • org.apache.spark:spark-core_2.13Maven

    From 3.3.0 · fixed in 3.3.1

  • org.apache.spark:spark-core_2.12Maven

    fixed in 3.2.2

  • org.apache.spark:spark-core_2.12Maven

    From 3.3.0 · fixed in 3.3.1

  • org.apache.spark:spark-core_2.11Maven

    All versions

  • org.apache.spark:spark-core_2.10Maven

    All versions

References 2

lists.apache.org

openwall.com