Skip to main content
← All vulnerabilities
CVE-2022-31692GHSA-MMMH-WCXM-2WR4

Spring Security, versions 5.7 prior to 5.7.5 and 5.6 prior to 5.6.9 could be susceptible to authorization rules bypass via forward or includ

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.7.5, 5.6.9
2 proofs of concept on GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Spring Security, versions 5.7 prior to 5.7.5 and 5.6 prior to 5.6.9 could be susceptible to authorization rules bypass via forward or include dispatcher types. Specifically, an application is vulnerable when all of the following are true: The application expects that Spring Security applies security to forward and include dispatcher types. The application uses the AuthorizationFilter either manually or via the authorizeHttpRequests() method. The application configures the FilterChainProxy to apply to forward and/or include requests (e.g. spring.security.filter.dispatcher-types = request, error, async, forward, include). The application may forward or include the request to a higher privilege-secured endpoint.The application configures Spring Security to apply to every dispatcher type via authorizeHttpRequests().shouldFilterAllDispatcherTypes(true)

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • n/a Spring by VMware

    Version range not reported

  • org.springframework.security:spring-security-coreMaven

    From 5.7.0 · fixed in 5.7.5

  • org.springframework.security:spring-security-coreMaven

    From 5.6.0 · fixed in 5.6.9

References 4

tanzu.vmware.com

security.netapp.com

GitHub · blipzip/cve-2022-31692

GitHub · hotblac/cve-2022-31692