Skip to main content
← All vulnerabilities
CVE-2022-31690GHSA-32VJ-V39G-JH23

Spring Security, versions 5.7 prior to 5.7.5, and 5.6 prior to 5.6.9, and older unsupported versions could be susceptible to a privilege esc

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.7.5, 5.6.9
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Spring Security, versions 5.7 prior to 5.7.5, and 5.6 prior to 5.6.9, and older unsupported versions could be susceptible to a privilege escalation under certain conditions. A malicious user or attacker can modify a request initiated by the Client (via the browser) to the Authorization Server which can lead to a privilege escalation on the subsequent approval. This scenario can happen if the Authorization Server responds with an OAuth2 Access Token Response containing an empty scope list (per RFC 6749, Section 5.1) on the subsequent request to the token endpoint to obtain the access token.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • n/a Spring Security

    Version range not reported

  • org.springframework.security:spring-security-oauth2-clientMaven

    From 5.7.0 · fixed in 5.7.5

  • org.springframework.security:spring-security-oauth2-clientMaven

    fixed in 5.6.9

References 2

tanzu.vmware.com

security.netapp.com