Skip to main content
← All vulnerabilities
CVE-2022-31626

mysqlnd/pdo password buffer overflow

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.4.30, 8.0.20, 8.1.7
2 proofs of concept on GitHub

Summary

In PHP versions 7.4.x below 7.4.30, 8.0.x below 8.0.20, and 8.1.x below 8.1.7, when pdo_mysql extension with mysqlnd driver, if the third party is allowed to supply host to connect to and the password for the connection, password of excessive length can trigger a buffer overflow in PHP, which can lead to a remote code execution vulnerability.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • PHP Group PHP

    From 7.4.X · fixed in 7.4.30; From 8.0.X · fixed in 8.0.20; From 8.1.X · fixed in 8.1.7

References 9

bugs.php.net

lists.fedoraproject.org

debian.org

security.netapp.com

security.gentoo.org

lists.debian.org

GitHub · HORKimhab/CVE-2022-31626-CVE-2024-2961-CVE-2019-6977

GitHub · amitlttwo/CVE-2022-31626