Skip to main content
← All vulnerabilities
CVE-2022-31115GHSA-977C-63XQ-CGW3

Unsafe YAML deserialization in opensearch-ruby

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.1, 2.0.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

opensearch-ruby is a community-driven, open source fork of elasticsearch-ruby. In versions prior to 2.0.1 the ruby `YAML.load` function was used instead of `YAML.safe_load`. As a result opensearch-ruby 2.0.0 and prior can lead to unsafe deserialization using YAML.load if the response is of type YAML. An attacker must be in control of an opensearch server and convince the victim to connect to it in order to exploit this vulnerability. The problem has been patched in opensearch-ruby gem version 2.0.1. Users are advised to upgrade. There are no known workarounds for this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • opensearch-project opensearch-ruby

    fixed in 2.0.1

  • opensearch-rubyRubyGems

    From 2.0.0 · fixed in 2.0.2

References 3

GitHub · opensearch-project/opensearch-ruby

staaldraad.github.io