Skip to main content
← All vulnerabilities
CVE-2022-31114GHSA-M8XX-3X29-84H8

backpack/crud Vulnerable to Cross-site Scripting

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.0.13, 4.1.69, 4.0.63
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. Versions prior to 5.0.13, 4.1.69, and 4.0.63 are vulnerable to cross-site scripting. An attacker could conduct a targeted phishing campaign, in order to trick users or admins into clicking a malicious link, which under very specific circumstances could give them information or possibly admin access. Versions 5.0.13, 4.1.69, and 4.0.63 patch the issue. As a workaround, manually look inside error views in `resources/views/errors` and output `e($exception->getMessage())` instead of `$exception->getMessage()`.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Laravel-Backpack CRUD

    From 5.0.0 · fixed in 5.0.13; From 4.0.0 · fixed in 4.1.69; fixed in 4.0.63

  • backpack/crudPackagist

    From 5.0.0 · fixed in 5.0.13

  • backpack/crudPackagist

    From 4.1.0 · fixed in 4.1.69

  • backpack/crudPackagist

    fixed in 4.0.63

References 1

GitHub · Laravel-Backpack/CRUD