Skip to main content
← All vulnerabilities
CVE-2022-31048GHSA-3R95-23JP-MHVGBIT-TYPO3-2022-31048

Cross-Site Scripting in Form Framework

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.7.47, 9.5.34, 10.4.29, 11.5.11, 9.5.35
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

TYPO3 is an open source web content management system. Prior to versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11, the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. TYPO3 versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • TYPO3 typo3

    From 8.0.0 · fixed in 8.7.47; From 9.0.0 · fixed in 9.5.34; From 10.0.0 · fixed in 10.4.29; From 11.0.0 · fixed in 11.5.11

  • typo3/cms-corePackagist

    From 8.0.0 · fixed in 8.7.47

  • typo3/cms-corePackagist

    From 9.0.0 · fixed in 9.5.35

  • typo3/cms-corePackagist

    From 10.0.0 · fixed in 10.4.29

  • typo3/cms-corePackagist

    From 11.0.0 · fixed in 11.5.11

  • typo3/cmsPackagist

    From 10.0.0 · fixed in 10.4.29

  • typo3/cmsPackagist

    From 11.0.0 · fixed in 11.5.11

References 3

GitHub · TYPO3/typo3

typo3.org