Skip to main content
← All vulnerabilities
CVE-2022-3030

An improper access control issue in GitLab CE/EE affecting all versions starting before 15.1.6, all versions from 15.2 before 15.2.4, all ve

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 15.1.6, 15.2.4, 15.3.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

An improper access control issue in GitLab CE/EE affecting all versions starting before 15.1.6, all versions from 15.2 before 15.2.4, all versions from 15.3 before 15.3.2 allows disclosure of pipeline status to unauthorized users.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • GitLab GitLab

    fixed in 15.1.6; From 15.2 · fixed in 15.2.4; From 15.3 · fixed in 15.3.2

References 3

gitlab.com

hackerone.com