CVE-2022-30123GHSA-WQ4H-7R42-5HRR
A sequence injection vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 which could allow is a possible shell escape in the Lint a
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.0.9.1, 2.1.4.1, 2.2.3.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A sequence injection vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 which could allow is a possible shell escape in the Lint and CommonLogger components of Rack.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a https://github.com/rack/rack
Version range not reported
- rackRubyGems
fixed in 2.0.9.1
- rackRubyGems
From 2.1 · fixed in 2.1.4.1
- rackRubyGems
From 2.2 · fixed in 2.2.3.1