Skip to main content
← All vulnerabilities
CVE-2022-2992

A vulnerability in GitLab CE/EE affecting all versions from 11.10 prior to 15.1.6, 15.2 to 15.2.4, 15.3 to 15.3.2 allows an authenticated us

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 15.1.6, 15.2.4, 15.3.2
1 Metasploit module, 2 proofs of concept on GitHub
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: total

Summary

A vulnerability in GitLab CE/EE affecting all versions from 11.10 prior to 15.1.6, 15.2 to 15.2.4, 15.3 to 15.3.2 allows an authenticated user to achieve remote code execution via the Import from GitHub API endpoint.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: yes · Technical impact: total

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • GitLab GitLab

    From 11.10 · fixed in 15.1.6; From 15.2 · fixed in 15.2.4; From 15.3 · fixed in 15.3.2

References 7

gitlab.com

hackerone.com

packetstormsecurity.com

GitHub · rapid7/metasploit-framework

GitHub · CsEnox/CVE-2022-2992

GitHub · Malwareman007/CVE-2022-2992