Skip to main content
← All vulnerabilities
CVE-2022-29257GHSA-77XC-HJV8-WW97

Electron's AutoUpdater module fails to validate certain nested components of the bundle

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 15.5.5, 16.2.6, 17.2.0, 15.5.0, 16.2.0, and 1 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Electron is a framework for writing cross-platform desktop applications using JavaScript (JS), HTML, and CSS. A vulnerability in versions prior to 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 allows attackers who have control over a given apps update server / update storage to serve maliciously crafted update packages that pass the code signing validation check but contain malicious code in some components. This kind of attack would require significant privileges in a potential victim's own auto updating infrastructure and the ease of that attack entirely depends on the potential victim's infrastructure security. Electron versions 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 contain a fix for this issue. There are no known workarounds.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • electron electron

    fixed in 15.5.5; From 16.0.0-beta.1 · fixed in 16.2.6; From 17.0.0-beta.1 · fixed in 17.2.0; From 18.0.0-beta.1 · through 18.0.0-beta.5

  • electronnpm

    fixed in 15.5.0

  • electronnpm

    From 16.0.0 · fixed in 16.2.0

  • electronnpm

    From 17.0.0 · fixed in 17.2.0

  • electronnpm

    From 18.0.0-beta.1 · fixed in 18.0.0-beta.6

References 1

GitHub · electron/electron