Skip to main content
← All vulnerabilities
CVE-2022-29248GHSA-CWMX-HCRQ-MHC3BIT-DRUPAL-2022-29248DRUPAL-CORE-2022-010

Cross-domain cookie leakage in Guzzle

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 6.5.6, 7.4.3, 9.2.20, 9.3.14
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Guzzle is a PHP HTTP client. Guzzle prior to versions 6.5.6 and 7.4.3 contains a vulnerability with the cookie middleware. The vulnerability is that it is not checked if the cookie domain equals the domain of the server which sets the cookie via the Set-Cookie header, allowing a malicious server to set cookies for unrelated domains. The cookie middleware is disabled by default, so most library consumers will not be affected by this issue. Only those who manually add the cookie middleware to the handler stack or construct the client with ['cookies' => true] are affected. Moreover, those who do not use the same Guzzle client to call multiple domains and have disabled redirect forwarding are not affected by this vulnerability. Guzzle versions 6.5.6 and 7.4.3 contain a patch for this issue. As a workaround, turn off the cookie middleware.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • guzzle guzzle

    fixed in 6.5.6; From 7.0.0 · fixed in 7.4.3

  • guzzlehttp/guzzlePackagist

    fixed in 6.5.6

  • guzzlehttp/guzzlePackagist

    From 7.0.0 · fixed in 7.4.3

  • drupal/corePackagist

    From 8.0.0 · fixed in 9.2.20; From 9.3.0 · fixed in 9.3.14

References 5

GitHub · guzzle/guzzle

drupal.org

debian.org